I'm having problems using Folksy with Internet Explorer

In general Folksy supports the current and prior release of Safari, Firefox, Chrome and Internet Explorer. 

Therefore depending upon the version of Internet Explorer you are using, you may experience some issues with using Folksy. Folksy no longer supports Internet Explorer 7 but does support IE8 with the caveat that the design will not look the same as they do in more modern browsers. 

We recommend using the latest version of Internet Explorer, Safari, Firefox or Chrome.

Feedback and Knowledge Base